Asterisk - Mon Expérience


Flux RSS
Tous les problèmes que j'ai pu rencontrer durant mes installations ou mes configurations.
Les problèmes rencontrés : Pas de son dans un sens.
Posté par francky le 25/12/2006 6:58:14 (9655 lectures)
Les problèmes rencontrés

Il  est possible que vous n'ayez pas de son dans un sens lors d'un appel vers l'extérieur sur une extention SIP ou faisceau SIP.

Il faut dans ce cas, renseigner le NAT. (Network Address Translation) ou, "Translation d'Adresse Réseau", ce qui permet de faire une liaison entre le serveur asterisk  et le WAN (Internet), dans notre cas.

Il faut valider dans ce cas, tputes les extentions qui seront sur le WAN.:

  • nat = yes

 

Celles qui seront sur votre LAN, n'auront pas besoin du NAT.!

Note: 0.00 (0 votes) - Noter cet article - Lire la suite... | 1633 octets en plus | Commentaires ?
Les problèmes rencontrés : Pas de prise en compte des modifications
Posté par francky le 3/12/2006 7:08:23 (971 lectures)

Lors d'une mise à jour hasardeuse d'asterisk, un problème de prise en compte des modifications faite via Freepbx arriva.

D'abord, un problème de messagerie vocale. Le problèmes était que l'on ne puisse plus déposer un message, ni une annonce personnalisée. On obtenait directement un message vocal: "Une erreur c'est produite"

Le répertoire var/spool/asterisk/voicemail/default n'existait plus . Après re-création des répoertoires, en n'oubliant pas de leur mettre les droits (privilèges) via les commandes (chmod, chgrp et chown), le problème avait disparu et je pouvais enfin déposer des messages.

Note: 0.00 (0 votes) - Noter cet article - Lire la suite... | 2570 octets en plus | Commentaires ?
Les problèmes rencontrés : Le faisceau SIP inaccessible soudainement
Posté par francky le 2/12/2006 7:25:08 (2050 lectures)

Il se peut qu’un moment vous trouviez votre faisceau entrant ou sortant dans un état “UNREACHABLE” ou Inaccesssible.

En regardant les log d’asterisk:

Target address x.x.x.x is not local, substituting externip

Dans la configuration qui est la mienne, j’ai réussi à retrouver un fontionnement normal. Malgrés plusieurs tentatives (Shutdown, restart now …Etc), ça n’avait rien donné :( !

Note: 0.00 (0 votes) - Noter cet article - Lire la suite... | 1023 octets en plus | Commentaires ?



 

Powered by XOOPS 2.0 © 2001-2006 The XOOPS Project
Recherche


Recherche avancée

Menu principal