Asterisk - Mon Expérience


Les problèmes rencontrés : Pas de son dans un sens.
Posté par francky le 25/12/2006 6:58:14 (9507 lectures)
Les problèmes rencontrés

Il  est possible que vous n'ayez pas de son dans un sens lors d'un appel vers l'extérieur sur une extention SIP ou faisceau SIP.

Il faut dans ce cas, renseigner le NAT. (Network Address Translation) ou, "Translation d'Adresse Réseau", ce qui permet de faire une liaison entre le serveur asterisk  et le WAN (Internet), dans notre cas.

Il faut valider dans ce cas, tputes les extentions qui seront sur le WAN.:

  • nat = yes

 

Celles qui seront sur votre LAN, n'auront pas besoin du NAT.!



En suite, il y a le fichie sip_nat.conf , qui doit être renseigné.

nat=yes externhost=url du serveur côté WAN
localnet=@IP locale/255.255.255.0
externrefresh=1 (en minute)


Valider puis relancer asterisk.

Il est possible aussi, que malgré que vous ayez faites ces modifications, qu'il n'y ait toujours pas de son.  Dans ce cas, faites attentions au paramètre canreinvite qui peut avoir son importance. IL faut le mettre à no s'il est à yes.

Le choix des Codecs aussi est important.  Dans ce cas, dévalidez tout puis revalidez les codecs souhaités:


disallow=all
allow=ulaw;alaw;gsm


Franck

 

Note: 0.00 (0 votes) - Noter cet article -
Format imprimable Envoyer cet article à un ami Créer un fichier PDF à partir de cet article
Les commentaires appartiennent à leurs auteurs. Nous ne sommes pas responsables de leur contenu.



 

Powered by XOOPS 2.0 © 2001-2006 The XOOPS Project
Recherche


Recherche avancée

Menu principal